brBrbr,エラー,原因,対処方法
WordPressのプラグイン「brBrbr」を入れると、エラーが発生する!(汗)

2017年以降にWordPressを始めた人で、こんな悩みを抱えている人は多いのではないでしょうか?
brBrbrはテキストエディタを使用するユーザー必須のプラグインだけあって、これが使えないのはかなりキツイですね。

ということで、今回はbrBrbrのエラーの対処方法と原因についてまとめていきます。

brBrbrのエラーの対処方法


brBrbrのエラーを修正するのは、コピペでいけちゃいます。
※と、偉そうなことを言っていますが、NOROSHIさんのやり方を引用させていただいております…汗

【エラー対処方法・1】メニュー→プラグイン→brBrbrを選択


brBrbrがインストールされている状態で、WordPressのメニュー画面から『プラグイン』を選択します。

brBrbr,エラー,原因,対処方法
そして『インストール済みプラグイン』を選択します。


次にbrBrbrの「編集」をクリックしましょう。

【エラー対処方法・2】コードを書き換える


さて、ここからはbrBrbr.phpのコードをイジるので、必ずバックアップをとっておきましょう。

brBrbr,エラー,原因
コードをコピーしたら、メモ帳にでもバックアップとして貼り付けておきましょう。

バックアップがとり終わったら、以下のコードをいじります↓↓


この3行分のコードを一旦、消します。


んで、代わりに以下のコードを貼り付けます。





そして、忘れずに「ファイルの更新」をクリックしてくださいね。


これで、brBrbrのエラーは解消されているはずです。


brBrbrエラーの原因とは


brBrbrのエラーの原因は、WordPressのPHPバージョンによるモノです。

2017年以前でしたら、PHPVer5.6.22がデフォルトだったのですが、現在ではPHPVer7.0が主流になっています。

PHPのバージョンにbrBrbrが対応できなくなってしまったのが原因なんですよね。
僕もこの方法を知るまでは、我慢してPHP5.6.22を使用していたのですが、ようやく最新版PHPでWordPressを使用できます(笑)

しかし、今後もWordPressのアップデートには注意しないといけませんね。
古いプラグインなどを入れていたらエラーが発生してしまう恐れがありますから。

さいごに


今回はWordPressのプラグインbrBrbrのエラーの対処方法と原因についてご紹介しました。

ご紹介しましたと言っても、完全に受け売りのやり方です(笑)
PHPバージョンの違いで、他のプラグインでお困りの方がいればNOROSHIさんを見たら解決できるかもしれません。

是非、そちらも参考にしてみてください!